Unable to log into the supervisor with the vcf client
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Unable to log into the supervisor with the vcf client

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Article ID: 417617

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

Logging into the supervisor using the vcf client shows the error: vcf client not found.

Error: unable to get cluster client while listing kubernetes clusters: unable to get client: Failed to invoke API on cluster : Get "https://XX.XX.XX.XX:443/version?timeout=32s": getting credentials: exec: executable vcf not found

It looks like you are trying to use a client-go credential plugin that is not installed.

[i] Auth type OIDC detected. Proceeding for authentication...

<TIMESTAMP> UTC  oidcclient/login.go:829  could not open browser  {"error": "exec: \"xdg-open,x-www-browser,www-browser\": executable file not found in $PATH"}

Environment

vSphere Kubernetes Service 9

Cause

If the vSphere Kubernetes Service (VKS) was deployed through VCF, VKS's identity provider will be configured to use VCF Automation's identity provider. The VCF CLI will detect this and attempt to authenticate requests through VCF Automation. 

Resolution

If you want to bypass VCF Automation and authenticated against vCenter's SSO configured identity sources, use the --auth-type basic option when creating a context:

vcf context create --endpoint=<SUPERVISOR_IP/URL> --username [email protected] --workload-cluster-name cluster1 --workload-cluster-namespace lab --auth-type basic