The SYMCScan service has stopped and can not be restarted.
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The SYMCScan service has stopped and can not be restarted.

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Article ID: 417616

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

Your Symantec Protection Engine (SPE) service has stopped and can not be restarted.  A review of the SymantecProtectionEngineAbortLog.txt shows the following:

400 CSAPI failed to initialize.
0 Symantec Protection Engine is shutting down; logs may contain more information.

When CSAPI logs are enabled the following is noted:

  • Windows:
    ERROR, SGS]	CLocalStargateScanner::Initialize(), Stargate digest directory unset. Digest directory: C:\Program Files\Symantec\Scan Engine\definitions\Stargate\digest [csapi_cstargatescanner.cpp:263(CLocalStargateScanner::Initialize)]
    
  • Linux
    ERROR, SGS]	CLocalStargateScanner::Initialize(), Stargate digest directory unset. Digest directory: /opt/SYMCScan/bin/definitions/Stargate/digest [csapi_cstargatescanner.cpp:263(Initialize)]

Environment

SPE 9.x 

Cause

The /opt/SYMCScan/bin/definitions/Stargate/digest or C:\Program Files\Symantec\Scan Engine\definitions\Stargate\digest directory is missing.

Resolution

Re-bootstrap stargate by performing the following steps

  1. Stop the SPE service:
    • Windows
      net stop SYMCScan
    • Linux:
      sudo /etc/init.d/symcscan stop
  2. Create a copy of the existing Stargate folder:
    • Windows:
      cp C:\Program Files\Symantec\Scan Engine\definitions\Stargate\ C:\Program Files\Symantec\Scan Engine\definitions\Stargate-backup
    • Linux
      mv /opt/SYMCScan/bin/definitions/Stargate/ /opt/SYMCScan/bin/definitions/Stargate-backup
  3. Create new Stargate Home directory:
    • Windows:
      mkdir C:\Program Files\Symantec\Scan Engine\definitions\Stargate\
    • Linux:
      mkdir /opt/SYMCScan/bin/definitions/Stargate
  4. Copy the contents of the master directory from Stargate-backup to the newly created Stargate directory:
    • Windows:
      copy C:\Program Files\Symantec\Scan Engine\definitions\Stargate-backup\master C:\Program Files\Symantec\Scan Engine\definitions\Stargate\
    • Linux
      cp -r /opt/SYMCScan/bin/definitions/Stargate-backup/master/*  /opt/SYMCScan/bin/definitions/Stargate
  5. Restart the SPE service:
    • Windows:
      net start SYMCScan
    • Linux:
      sudo /etc/init.d/symcscan resetart

Additional Information

If the above steps do not resolve the issue for a SPE on Windows then re-run the SPE installer and choose the "Repair" option.