You see inaccessible virtual objects while vSAN Skyline Health reports "vSAN Cluster Partition" and "vSAN Object Health" errors.
search cancel

You see inaccessible virtual objects while vSAN Skyline Health reports "vSAN Cluster Partition" and "vSAN Object Health" errors.

book

Article ID: 417612

calendar_today

Updated On:

Products

VMware vSAN VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

  • When checking Virtual Objects (Cluster -> Monitor -> vSAN -> Virtual Objects), you see inaccessible objects. 
  • You see a vSAN Skyline Health reporting a vSAN Cluster Partition:

 

  • You also see vSAN Skyline Health reporting "vSAN Object Health Error":

 

  • All VM's appear to be accessible and running, as expected. 

 

Environment

  • VMware vSAN 8.x

Cause

  • The partitioned vSAN node was in that state while VM's  were deleted from inventory, so had not updated the Cluster Monitoring, Membership, and Directory Service (CMMDS) properly. 

  • You can validate the owning host of the inaccessible objects from an ssh session on one of the ESXi hosts in that cluster as follows:

esxcli vsan debug object list -u <uuid>

...where the UUID of the inaccessible object is found in the Virtual Object List (Cluster -> Monitor Tab -> Virtual Objects -> Click on "Inaccessible")

NOTE: When you perform the same command on one of the hosts that is still in the primary partition, the object is not found. 

 

Resolution

  • You will need to troubleshoot and resolve the vSAN Cluster partition first. For more information on troubleshooting vSAN Cluster Partitions, see KB: vSAN Health Service - Network Health - vSAN Cluster Partition.

  • If the host appears to be no longer partitioned (e.g. all nodes can ping each other, all firewall ports are confirmed open, etc.), but a "retest" in Skyline Health (Cluster -> Monitor Tab -> Skyline Health -> Retest) still reports the host in a partitioned state, place the host into maintenance mode and reboot it. 

  • If you are having trouble resolving the partition or if the partitioned state is cleared and you still have inaccessible objects after the reboot, please open a support case with Broadcom Support for further assistance.