JRS related jobs of Clarity fail when trying to connect to the server
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JRS related jobs of Clarity fail when trying to connect to the server

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Article ID: 417536

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

  • There are several Jaspersoft Reports Server related jobs in Clarity, such as 'Restore Domains, 'Load Data Warehouse' etc.
  • These jobs fail with the following error when trying to connect to the server:
    • java.lang.RuntimeException: Exception getting ClarityJasperAdmin : Connect to example.com:8080 [example.com/10.10.10.10] failed: Connect timed out
  • telnet from the Clarity server to the Jaspersoft server on port 8080 also fails

Cause

  • Jaspersoft Server is not running
    • or
  • Wrong Jaspersoft Apache Tomcat server is running

Resolution

Check if the correct Jaspersoft Apache Tomcat is running. If using startup.bat in the Apache Tomcat's bin directory to start the server, then do not close the additional Command Line Interface (CLI) that it opens, in a Windows Server host.