argTenantID error when trying to create a New Configuration Item Relationship
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argTenantID error when trying to create a New Configuration Item Relationship

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Article ID: 417532

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When trying to add a new configuration Item relationship to a configuration item (CI), SDM hangs and does not allow saving or canceling changes. This issue occurs with OOTB roles like Configuration Administrator. 

The F12 Developer console shows the following error:

Uncaught ReferenceError: argTenantId is not defined
    at loadActions (pdmweb.exe?

No error is logged in NX_ROOT\log\stdlog

Environment

SDM 17.4 RU5 and previous releases

Multi-tenant enabled and set in "setup" mode. 

Cause

This issue is caused by a defect with SDM 17.4 RU5 and previous versions.

Resolution

Workaround: Customize the OOTB detail_bmhier.htmpl form using Web Screen Painter, following the supported steps, and change the following code.

FROM:

if ( argTenantId == "" )

TO

if ( typeof argTenantId != "undefined" && argTenantId == "" )

 

Solution: The fix will be included in 17.4 RU6 and 17.5.