Issue:
While trying to use bulk loader client, it shows the following error:
Failed to submit data to server
ImsException caught:
Fault Code: Client
Fault String: Error performing operation.
Exceptions:
Name:
Code: 500
Description: Exception encountered during task submission: No items found
ProcessStep::DataValidate TabName: ERRORLEVEL::Error
Environment:
Identity Manager r12.6 sp2
Cause:
The error thrown in logs was as follows:
ERROR [TaskServiceImpl] exception during validation [facility=4 severity=2 reason=0 status=38 message=No items found]
at com.netegrity.llsdk6.imsimpl.provider.AdminTaskProviderImpl.findByTag(AdminTaskProviderImpl.java:307)
This could mean that the task that is requested to run is not recognizable. It needs to be recognized by it's Task Tag. The Task Tag is the internal unique identifier of a task. You find it when Modify Admin Task -> select your task -> profile tab -> check out the Tag field. From your properties file, the elements here that are called: "Create User" , "Modify User" and "Delete User" are all supposed to be the tags of the tasks.
Resolution:
Look at all the tasks in the actionToTaskMapping and make sure these are the tags (not the Names) of these tasks.
For example, in the bulk loader client properties file, earlier value was:
actionToTaskMapping = create.Create User;modify.Modify User;delete.Delete User;bulk.Create xxxx Employee Bulk Load;enable.Enable/Disable User
Change it to:
actionToTaskMapping=create.Create User;modify.Modify User
Additional Information:
Don't select the enable web service check-box in task which is used for bulk loader client other than Bulk Loader task.