Unable to continue NSX upgrade with the error message "Upgrade failed: vSAN health test 'VMware vCenter and all hosts are connected to Key Management Servers' reported an issue for cluster"
search cancel

Unable to continue NSX upgrade with the error message "Upgrade failed: vSAN health test 'VMware vCenter and all hosts are connected to Key Management Servers' reported an issue for cluster"

book

Article ID: 417517

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • During the NSX upgrade of Transport Nodes, the upgrade process fails with the following error message:
Upgrade failed: vSAN health test 'VMware vCenter and all hosts are connected to Key Management Servers' reported an issue for cluster "<cluster_name>". Check the vSAN health.
Upgrade failed: Health Check for '<cluster_name>' failed.
  • In the NSX, System > Upgrade > Hosts > Clink on "Failed" bottom, the following error is displayed:

Environment

VMware NSX

Cause

The upgrade process failed because a vSAN health check reported an alert, which prevents the NSX upgrade from proceeding.



Resolution

Follow the steps described on the KB article: vSAN Health - VMware vCenter and all hosts are connected to Key Management Services

If you are unable to resolve this issue, please open a support case with Broadcom Support (vSAN team) and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.

Additional Information

vSAN Health - VMware vCenter and all hosts are connected to Key Management Services