"No Session" error in adminui and "Failed to decrypt persistent key error" in SMPS log.
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Article ID: 41750
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Updated On:
Products
CA Single Sign On Secure Proxy Server (SiteMinder)
CA Single Sign On SOA Security Manager (SiteMinder)
CA Single Sign-On
Issue/Introduction
Unable to register webagent with policy server, we see below error in smps.log
[SmObjKeyManagement.cpp:457][ERROR] Failed to decrypt persistent key.
While accessing the KeyManagement tab in adminui we will get no session error.
Environment
Policy server version:12.8.x
Cause
Agent keys are corrupted. More than one set of keys present in key store.
Resolution
Follow the below steps to register webagent with policy server.
- Backup the following tables on key-store database.
SMKEYMANAGEMENT4
SMAGENTKEY4
- After backup delete all records from below tables.
SMKEYMANAGEMENT4
SMAGENTKEY4
- Restart the Policy server.
- Restart WAMUI and try to access the Key management tab (this time we shouldn't see the "No session" error).
- Now go to Adminui>Administration>Policy Server>Key management tab rollover both static and session key.
- Verify smkeyexport contains only one set of keys. (smkeyexport -dSiteMinder -wpassword -o/temp/keys.txt -l -v -t -c)
- Now try to register webagent with PolicyServer.
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