CDM is sending internal alarms regarding CheckMemInfo - GetMemInfo failed (temporarily out of resources)
search cancel

CDM is sending internal alarms regarding CheckMemInfo - GetMemInfo failed (temporarily out of resources)

book

Article ID: 4175

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You may get spurious alarm messages that have the following text:


cdm:InternalAlarm: Unable to get Memory data (temporarily out of resources)
cdm:InternalAlarm: Unable to get CPU data (error)
cdm:InternalAlarm: Unable to get Memory data (error)

Environment

Cdm 5.x or above

AIX Systems:

Windows Systems

Cause

On AIX machines the commands CDM will run will timeout before completing. Changing the timeout will resolve the issue.

On some systems incorrect NTP settings can cause this issue

On Windows Systems the performance counters may have been corrupted

Resolution

On AIX Systems:

If you are receiving CPU alarms - add the following in raw configure:

<cpu> section of cdm

add a new key if it does not exist with the following value

sliced_cpu_interval = 30

If you are receiving memory alarms - add the following in raw configure:

<memory> section of cdm

sliced_memory_interval = 30

On Windows systems:

Work with the system administrator to rebuild the performance counters.  CDM probe uses these Windows components to collect the metrics.
If needed, go through the below link for “how to manually rebuild the performance counter library values “.
https://support.microsoft.com/en-us/kb/300956

On both systems:

Check that NTP settings are correct and accurate. A few seconds of  drift may cause this issue.