Error “Failed to propagate configuration to CP” when enabling log collection using collector/group in VMware Cloud Foundation (VCF) Operations 9.x
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Error “Failed to propagate configuration to CP” when enabling log collection using collector/group in VMware Cloud Foundation (VCF) Operations 9.x

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Article ID: 417347

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Attempting to configure Administration > Integration > VCF Adapter > expand VCF Instance > Edit vCenter Server Endpoint > Log Operations and enabling “Activate log collection” under Collect Logs (using the “Collect logs using the collector/group” option) completes successfully.
  • However, under Infrastructure Operations > Configurations > Log Collection, an error appears stating “Failed to propagate configuration to CP.”
  • You will see similar errors in /storage/log/vcops/log/collector.log 

    ERROR collector #### [ops@##### threadId="#####" threadName="ops-data-sdk-subscriber-thread-######"] [(###) com.broadcom.ops.data.vc.collect.VcCollector.onError] - Subscriber #######-####-#####-####-########## with queryId ### for source VC_STATS_ESX got error.
     com.vmware.vapi.client.exception.ConnectionException: https://<vCenter_Server_FQDN>:443/stats invocation failed with "java.net.SocketTimeoutException: Read timed out"
     at com.vmware.vapi.internal.protocol.client.rpc.http.HttpClient.send(HttpClient.java:188) 

Environment

VCF Operations 9.x
VCF Operations for logs 9.x

Cause

This issue occurs due to network latency exceeding the acceptable threshold between the VCF Operations nodes  and Cloud Proxy . According to the VCF Operations 9.x Sizing and Architecture Guidelines, the acceptable network latency must be less than 300 ms 

Resolution

To resolve the issue, ensure that the network latency between VCF Operations node and Cloud Proxy is less than 300 ms