In vIDM UI, all component are not loading within dashboard.
search cancel

In vIDM UI, all component are not loading within dashboard.

book

Article ID: 417345

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • vIDM Health Status show an error with ACS Health - Application Deployment Status - Web Application Status - Error when connecting to the application.
  • vIDM Health Status show an error with Application Manager - Application Deployment Status - Web Application Status - Error when connecting to the application.
  • vIDM Health Status not showing 'Integrated Components' section and it just loading or spinning.

Environment

VMware Identity Manager 3.3.7

Cause

1. /etc/krb5.conf file is missing.
2. /etc/hosts file is modified.

Resolution

Resolution:

  1. Took a snapshot of a cluster without a memory.
  2. Copy krb5.conf file from healthy node to affected node. Run below command from healthy node.
    scp /etc/krb5.conf root@affected_node_ip:/etc/krb5.conf
  3. Edit /etc/hosts file and make sure FQDN/Hostname is written in same way as shown below.
    i. vi /etc/hosts
     # Begin /etc/hosts (network card version)
     # End /etc/hosts (network card version)
     # Do not modify below values manually. Modifying below values would affect postgres clustering
     For Example:
       ##.##.##.## master
       ##.##.##.## delegateIP
     # VAMI_EDIT_BEGIN
     # Generated by Studio VAMI service. Do not modify manually.
     127.0.0.1  <FQDN> <hostname> localhost
     ::1 <hostname> <shortname> localhost ipv6-localhost ipv6-loopback

    ii. wq! to save the changes.

  4. Restart the horizon service on affected node.
    service horizon-workspace restart
  5. Go the vIDM Health dashboard and will see all components in a healthy state.