Disabled alarms may persist even after "Reset To Green" button is pressed.
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Disabled alarms may persist even after "Reset To Green" button is pressed.

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Article ID: 417279

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Even when you click Reset to Green, the alarm remains in vSphere Client. Although you can click the Reset to Green button, there is no response on the screen, and the alarm does not clear.
  • The alarm is disabled at the object level.
    For example, in the image above, when navigating to the datastore "nfs3" in the inventory and selecting the Configure tab > Alarm Definitions, the alarm Datastore usage on disk is shown as disabled. The alarm is enabled at the global level.
  • The alarm remains in vSphere Client even after the Reset Rule is satisfied.
    For example, in the image above, the alarm remains active even after the datastore usage drops below 75%.

Environment

VMware vCenter Server

Cause

When the following two conditions are met simultaneously for an alarm, it becomes impossible to clear the alarm using Reset to Green.

  • The alarm is in a triggered state.
  • The alarm is disabled at the object level.

Resolution

To clear an alarm, you need to enable the alarm at the object level and then perform a Reset to Green operation.
In the example shown in the image above, you would first enable the alarm Datastore usage on disk for nfs3 datastore, and then perform the Reset to Green operation:

  1. In the vSphere Client inventory, select the target object.
  2. Navigate to the Configure tab > Alarm Definitions.
  3. Select the alarm and click ENABLE.
  4. Now you can clear the alarm on the object. Click Reset to Green to clear the alarm.
  5. Re-disable the alarm by following steps 1 through 3 again.