Error recreating replication in VMware Cloud Director Availability
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Error recreating replication in VMware Cloud Director Availability

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Article ID: 417258

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Creating a new protection or migration completes, but an error similar to the following is seen:

    Failed to rename replication tracking VM '########-####-####-####-############'.

    Unexpected VMware Cloud Director error. [ UI-########-####-####-####-############-####-##-########-####-####-####-############ ] The VMware Cloud Director entity ########## already exists. - could not update: [com.vmware.vcloud.common.model.RtVAppVmModel#########-####-####-####-############] - ERROR: duplicate key value violates unique constraint "uk_vapp_vm_vapp_id_name" Detail: Key (vapp_id, name)=(########-####-####-####-############, ##########) already exists.

  • Attempting to perform a failover or test failover results in errors similar to the following:

    Failed to update the description of the recovered VM 'rtvm-C4-########-####-####-####-############'.

  • There is a virtual machine with the name from the error above (rtvm-C4-########-####-####-####-############) in the vCenter inventory.
  • There is no visible virtual machine with the name of the VM in the VMware Cloud Director user interface.

Environment

VMware Cloud Director Availability 4.7.3.x

Cause

There is an existing RTVM with that name that still exists in the VMware Cloud Director vApp, which is often caused by the previous removal of a replication that did not successfully clear the destination files. Since VMs are limited from having duplicate names in the same vApp, VMware Cloud Director Availability is unable to successfully rename the new RTVM.

Resolution

The existing RTVM will need to be reviewed and removed, if it is no longer viable. Since database modifications may be necessary to resolve this issue, this will require VMware Technical Support assistance. Please open a Support Request with VMware Technical Support and reference this KB article (417258) to remediate this behavior.