Error: "Internal Server Error - java.lang.NullPointerException" when recreating a replication
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Error: "Internal Server Error - java.lang.NullPointerException" when recreating a replication

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Article ID: 417258

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • There are two scenarios and related errors:     
    • Scenario 1 - There is a virtual machine with the name from the error above (rtvm-C4-########-####-####-####-############) in the vCenter inventory.
      • Creating a new protection or migration completes, but an error similar to the following is seen:

        Failed to rename replication tracking VM '########-####-####-####-############'.

        Unexpected VMware Cloud Director error. [ UI-########-####-####-####-############-####-##-########-####-####-####-############ ] The VMware Cloud Director entity ########## already exists. - could not update: [com.vmware.vcloud.common.model.RtVAppVmModel#########-####-####-####-############] - ERROR: duplicate key value violates unique constraint "uk_vapp_vm_vapp_id_name" Detail: Key (vapp_id, name)=(########-####-####-####-############, ##########) already exists.

      • Attempting to perform a failover or test failover results in errors similar to the following:

        Failed to update the description of the recovered VM 'rtvm-C4-########-####-####-####-############'.

    • Scenario 2 - Associated RT-VMs are not in vCenter 
      • When Recreating Replication replication shows error:

    •          Unexpected VMware Cloud Director error. [ UI-#####... ] Internal Server Error - java.lang.NullPointerException 
    •  
      • Cloud Director task for RT-VM shows error:

        Could not find object with moref "vm-#####" and VC ID "########-####-####-####-############" in inventory category "VirtualMachine".
  • For both scenarios, there is no visible virtual machine with the name of the VM/RT-VM in the VMware Cloud Director user interface.

Environment

  • VMware Cloud Director Availability 4.7.3.x
  • VMware Live Recovery 4.7.3

Cause

There is existing RT-VM data in Cloud Director causing the conflict when recreating the replication.

Resolution

The workaround for this issue requires modification of the Cloud Director database.

For assistance, contact Broadcom Support and note this Article ID (417258) in the problem description. For more information, see Creating and managing Broadcom support cases .