VSAN can not detect newly added disk
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VSAN can not detect newly added disk

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Article ID: 417257

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • A customer attempted to expand vSAN capacity by adding a new physical disks to a host that was in maintenance mode.
  • After the disk were physically installed, the vSphere UI showed the disks was ineligible to be claimed by vSAN.

Cause

  • Newly added disk had pre-existing partition tables.
  • The presence of a partition on a disk, often from previous use or formatting, causes vSAN to mark the disk as "ineligible" for claiming.
  • vSAN requires disks to be completely empty and without any partition information before they can be added to a disk group.

 

Resolution

The solution is to remove the existing partitions from the ineligible disks. This action clears the disk and allows vSAN to recognize it as available for claiming.

Step-by-Step Instructions:

  1. In the vSphere Client, navigate to the ESXi host where the new disk(s) were added.

  2. Go to the Configure tab and select Storage Devices under the Storage section.

  3. Identify the newly added disk(s) that are not available to be claimed in the vSAN disk management wizard.

  4. Select one of the ineligible disks.

  5. Review the Partition Details section. If any partitions are listed, they must be removed.

  6. Use the delete all existing partitions from the disk.

  7. Repeat this process for any other ineligible disk(s).

  8. Once the partitions are cleared, return to the vSAN disk management section (Cluster > Configure > vSAN > Disk Management).

  9. The disks should now appear as eligible and can be claimed to be added to the desired disk group.

Additional Information