On vSAN File Services on 8.0U3 P05 or above, some files or directories are not accessible
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On vSAN File Services on 8.0U3 P05 or above, some files or directories are not accessible

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Article ID: 417208

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Updated On:

Products

VMware vSAN 8.x

Issue/Introduction

  • A critical issue has been identified that only affects clusters with vSAN File Services enabled (OSA & ESA) that are upgraded to ESXi 8.0 Update 3e, 8.0 Update 3f, and 8.0 Update 3g.
  • In file shares upgraded from earlier versions to ESXi 8.0 Update 3e, 8.0 Update 3f, and 8.0 Update 3g some files and/or directories may become inaccessible under specific conditions.
  • This issue is not applicable to Greenfield installations of any version.
  • Please refer to the affected versions in the "Environment" section for the list of impacted versions

Environment

AFFECTED VERSIONS:

ESXi/ESX version Release Name Build Number Release date
ESXi 8.0.3 P06 ESXi 8.0 Update 3g 24859861 2025/07/29
ESXi 8.0.3 EP5 ESXi 8.0 Update 3f 24784735 2025/07/15
ESXi 8.0.2 EP4 ESXi 8.0 Update 2e 24789317 2025/07/15
ESXi 8.0.3 P05 ESXi 8.0 Update 3e 24674464 2025/04/10
ESX 9.0.1.0 ESX 9.0.1.0 24957456 2025/09/29
ESX 9.0.0.0100 ESX 9.0.0.0100 24813472 2025/07/15
ESX 9.0.0 ESX 9.0 GA 24755229 2025/06/17

Cause

  • Under rare conditions, an incomplete I/O commit may occur on file shares that existed from earlier releases, which may lead to file service unavailability
  • This issue occurs only in clusters that were upgraded from earlier versions (prior to  ESXi 8.0 Update 3e) to one of the affected versions listed in the “Environment” section.
  • The impact is limited to existing vSAN File Services shares that were present before upgrading ESXi 8.0 Update 3e or later.
  • New shares created after the upgrade to ESXi 8.0 Update 3e or later versions are not impacted by this issue

Resolution

  • This issue has been resolved in ESXi 8.0 Update 3h and will also be addressed in the upcoming quarterly 9.x patch release.

 

Steps post upgrading to 8.0 U3h

  • Post upgrading the cluster to ESXi 8.0 Update 3h, Broadcom recommends running the following diagnostic commands soon after the upgrade and avoid any large space reclamation operations on the shares until the steps have been executed.


Step 1: Download the below attached scripts files and upload them to the vCenter Server or any Linux distro client under /tmp

    1. share-health-checker.py
    2. README-share-health-checker.py

Step 2: The Readme file contains the instructions on how to run the diagnostic utility.

Step 3: Execute the script to perform a health check against all the vSAN FileService shares:

python3 share-health-checker.py  --host <ESXi_IP>  –user root

Step 4: User will prompted to enter the password for all the hosts to proceed

Step 5: Once completed, validate the health check summary

    • If any shares are listed under “IMPACTED SHARES”, please contact Broadcom Technical Support immediately for further assistance.

Step 6: Session output will be saved in share-health-checker.log on the client

Additional Information

  • Running this utility doesn’t require a maintenance window on the File Services.
  • The outcome of the diagnostic utility will highlight if any shares are impacted or not.
  • Script will log the session output to share-health-checker.log

 

 

Attachments

README-share-health-checker.md get_app
share-health-checker.py get_app