Unable to access the IGA XPress console
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Unable to access the IGA XPress console

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Article ID: 417124

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Updated On:

Products

CA Identity Manager

Issue/Introduction

After installing the IGA Xpress successfully, We get an error "site cannot be reached" while trying to access the IGA Xpress console with https://x.x.x.x:10443

Environment

IGA 15.0

Cause

Due to the Network configuration

Resolution

To address the IGA Xpress console issue, please try the steps below

 

1)Go to /opt/brcm/iga/inst/xpress/ folder
 
2)Edit run.sh
 
and modify it like the following (switch the binding to 0.0.0.0)
 
# production
#uvicorn --host :: --port 10443 --workers 2 main:app --log-config log.yaml --ssl-certfile $SERVER_CERT --ssl-keyfile $SERVER_KEY --no-server-header &
uvicorn --host 0.0.0.0 --port 10443 --workers 2 main:app --log-config log.yaml --ssl-certfile $SERVER_CERT --ssl-keyfile $SERVER_KEY --no-server-header &
 
Restart the IGA Xpress
$> igactl restart xpress
 
Then, check the status by executing the command below
$> netstat -ntulp | grep 10443
 

And now, try to access the IGA Xpress console