Unable to integrate Fleet Management with VCF Operations
search cancel

Unable to integrate Fleet Management with VCF Operations

book

Article ID: 417122

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Attempting to connect Fleet Management to VCF Operations(VCF Ops) following Register the VCF Operations fleet management Appliance with VCF Operations ,certificate prompt is accepted and the wizard disappears while leaving the status of Fleet Management in 'not connected' state.




  • In '/var/log/vrlcm/vmware_vrlcm.log' on the Fleet Management appliance, you notice following errors during service account creation:

    INFO vrlcm[1344] [pool-3-thread-85] [c.v.v.l.d.v.VropsEndpoint] – Continue if authorized
    INFO vrlcm[1344] [pool-3-thread-85] [c.v.v.l.p.c.v.t.VropsCreateServiceAccountTask] – Initialized VCF Ops Master Config
    INFO vrlcm[1344] [pool-3-thread-85] [c.v.v.l.d.v.VropsEndpoint] – Request to create service account in Ops : {
    "username" : "username",
    "password" : "password",
    "key" : "key"
    }

    INFO vrlcm[####] [pool-3-thread-70] [c.v.v.l.d.v.VropsEndpoint]  -- Create service account Response Code : 500 :: Response Body : {"error_message_key":"security.password.does_not_meet_requirements","error_arguments":KXKXKXKX,"error_message":"New password YXYXYXYX not meet complexity requirements."}
    ERROR vrlcm[[####]] [pool-3-thread-70] [c.v.v.l.p.c.v.t.VropsCreateServiceAccountTask]  -- Error occurred while creating service account Error occurred while creating service account
    INFO vrlcm[[####]] [pool-3-thread-70] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMVROPSYSTEM30020', Retry : 'true', Causing Properties : '{ CAUSE ::  }'
    java.lang.RuntimeException: Error occurred while creating service account


  • Similarly, in '/storage/log/vcops/log/casa/casa.log' on the VCF Operations appliance, you notice the following errors:

    INFO casa 1709 [ops@4413 threadId="397714" threadName="Thread-45196" requestId=" "] [com.vmware.vcops.casa.fleetmanagement.lcm.LCMInternalService.doLcmCallWi
    thResponse:153] - Request successful for GET request to <https://FleetManagement-URL/lcm/request/api/v2/requests/#####-#####-#####-#####-#####>
    INFO casa 1709 [ops@4413 threadId="397714" threadName="Thread-45196" requestId=" "] [com.vmware.vcops.casa.fleetmanagement.FleetManagementNodeService.run:261
    ] - ADD-FLEET-MANAGEMENT-NODE-WORKFLOW: LCM node state is: FAILED
    ERROR casa 1709 [ops@4413 threadId="397714" threadName="Thread-45196" requestId=" "] [com.vmware.vcops.casa.fleetmanagement.FleetManagementNodeService.run:267
    ] - Registration failed
    INFO casa 1709 [ops@4413 threadId="397714" threadName="Thread-45196" requestId=" "] [com.vmware.vcops.casa.fleetmanagement.FleetManagementNodeService.run:284
    ] - ADD-FLEET-MANAGEMENT-NODE-WORKFLOW: Cleanup: Closing restTemplate

Environment

VCF Operations 9.x
VCF Fleet Management 9.x

Cause

This issue occurs when there is a stale reference for Fleet Management service account (highlighted in vmware_vrlcm.log)  in VCF Operations, originating from past failed attempts.

Resolution

To resolve this issue, perform the following actions:

  1. Take snapshot of VCF Operations node and Fleet Management appliance.
  2. Take SSH session to Fleet management appliance
  3. Convert the VCF Operations admin credentials to base64 format using following command:

    echo -n 'admin:<VCFOps-admin-password>' | base64

    For ex: echo -n 'admin:Test123!' | base64

  4. Issue the following API against VCF Operations address to delete service account "reported in vmware_vrlcm.log" from the Fleet management appliance.  The path to the file is /var/log/vrlcm. 

    curl -k --request DELETE --url https://VCFOps_URL/casa/auth/users --header 'accept: application/json' --header 'authorization: Basic base64Credentials from step.2' --header 'content-type: application/json' - data '{ "username": "username reported in vmware_vrlcm.log", "key": "key reported in vmware_vrlcm.log" }'

  5. Connect the Fleet Management to VCF Operations following Register the VCF Operations fleet management Appliance with VCF Operations .


If the issue persists,  please open a Support Request with Broadcom Technical Support and note this Article ID (417122) in the problem description. For more information, see Creating and managing Broadcom support cases.