Greenplum Disaster Recovery (gpdr) Continuous Restore Fails Due to a Hole in WAL
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Greenplum Disaster Recovery (gpdr) Continuous Restore Fails Due to a Hole in WAL

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Article ID: 417085

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Updated On:

Products

VMware Tanzu Data Suite VMware Tanzu Greenplum

Issue/Introduction

Greenplum Disaster Recovery (gpdr) continuous restore may fail due to a hole (gap) in the Write-Ahead Log (WAL) archive. 

Symptoms and Error Signs

  • The gpdr continuous restore process stops with errors referencing missing or corrupt WAL files.
  • Logs on the coordinator or segment hosts report issues such as:
    • “missing WAL segment”
    • “requested WAL segment ... has already been removed”
    • Archive or archive_command failures.

Environment

  • Applies to all gpdr versions below 1.4.0.

Cause

A hole in the WAL archive—missing WAL files—prevents successful replay of logs during restore, causing the continuous restore process to fail.

Resolution

  • Contact Broadcom Greenplum Support to assist with the recovery and investigation of WAL archive gaps.
  • Upgrade to the latest gpdr release (1.4.0 or later), which includes improvements to better handle orphaned or missing WAL files during restore.

Additional Information

References