HCX NE pair in UNDECIDED state
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HCX NE pair in UNDECIDED state

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Article ID: 416990

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Updated On:

Products

VMware HCX

Issue/Introduction

  • HCX NE appliance role shows UNDECIDED for some NE appliances.

 

  • Check for the uplink connectivity status from var/log/system_events, or run health check using command "hc -d" on the affected appliance and check the tunnel status of NE appliances.

Refer the following KB for health check on HCX - https://knowledge.broadcom.com/external/article/325021/hcx-how-to-check-hcx-appliances-status-i.html

  • Irrespective of the "Undecided" state of the NE HA pair, the logs in var/log/system_events from NE appliance reports the the NE tunnel is 'UP'

{"id":20003,"level":2,"timestamp":1760772005,"UTC":"2025-10-18T07:20:05Z","message":"IPIP_FOU Tunnel is up","metadata":{"tunnelId":"te_0","tunnelType":"IPIP_FOU"}}

{"id":60007,"level":2,"timestamp":1760772021,"UTC":"2025-10-18T07:20:21Z","message":"HA State Transition","metadata":{"from":"state:unready","to":"state:ready"}}

  • You may find the logs similar to the following in /common/logs/admin/app.log

####-##-## 19:42:06.797 UTC [InterconnectStatsService_SvcThread-88197, Ent: HybridityAdmin, ] WARN c.v.v.h.s.i.s.InterconnectApplianceStatsCollectionJob- Storing state of appliance ########-7d6b-41f0-####-61f9######## as {"applianceId":"########-7d6b-####-b073-61f9########","stateResource":{"state":"UNREADY","role":"UNDECIDED"}}.

Environment

VMware HCX

Cause

Generally the connectivity problem is likely caused by underlying connectivity issues.

Resolution

If no uplink connectivity issue between the appliances or appliance role remains UNDECIDED even after uplink restored, then follow the below work around

  • Reboot the affected NE appliance.
  • If reboot cannot fix this issue, redeploy NE pair under maintenance window.
  • If standard redeploy does not work issue a force redeploy of the impacted appliance.

Additional Information

If you believe you have encountered this issue and need technical assistance, please open a support case with Broadcom Support and refer to this KB article. 
For more information, see Creating and managing Broadcom support cases.