Upgraded to CETN600 and the MSMCPROC gets error : MSMC0501E SQL PREPARE VERSIONSTMT for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0000'
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Upgraded to CETN600 and the MSMCPROC gets error : MSMC0501E SQL PREPARE VERSIONSTMT for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0000'

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Article ID: 41698

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CIS COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services Datacom/AD CA ECOMETER SERVER COMPONENT FOC Easytrieve Report Generator for Common Services INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA ON DEMAND PORTAL CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware Compress Data Compression for MVS Compress Data Compression for Fujitsu Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

 

Symptoms: 

A systems programmer reports that he had implemented CA Common Services maintenance and in the process upgraded the FMID for the CA CSM Common Services component from CETN500 to CETN600.

Since this upgrade the MSMCPROC now reports the following errors:

 

MSMC0423I Task MSMCFCOM database connection opened                                                         
MSMC0501E SQL PREPARE VERSIONSTMT for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=,        
         IRETCODE=X'0000'                                                                                  
MSMC0503E SQL error message: PROGRAM TIMESTAMP 374699744 NOT = PLAN TIMESTAMP 319477894                    
MSMC0501E SQL ROLLBACK for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0000'  
MSMC0503E SQL error message: PROGRAM TIMESTAMP 374699744 NOT = PLAN TIMESTAMP 319477894                    
MSMC1000I Auxiliary AS Scheduler Started                                                                   
MSMC0401E EVTINIT for task MSMCIES0 failed, RETCODE=X'00000020'                                            
DB00101I - STARTED JOB-MSMCPROC NUMBER-87893 CXX=CAMSM    MUFNAME=MSMR5MUF SVC=247                         
MSMC0423I Task MSMCIENG database connection opened                                                         
MSMC0501E SQL PREPARE_CFGPROF for task MSMCIENG failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0
MSMC0501E SQL ROLLBACK for task MSMCIENG failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0000'  
MSMC0424I Task MSMCIENG database connection closed                                                         
MSMC0401E EVTINIT for task MSMCIENG failed, RETCODE=X'00000020'                                            
MSMC0401E EVTINIT for task MSMCCEVH failed, RETCODE=X'00000020'                                            
MSMC0002I SCS initialization complete, SYSNAME=ONL1, CCINAME=ONL1                                          
MSMC0501E SQL PREPARE VERSIONSTMT for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=,        
         IRETCODE=X'0000'                                                                                  
MSMC0503E SQL error message: PROGRAM TIMESTAMP 374699744 NOT = PLAN TIMESTAMP 319477894                    
MSMC0501E SQL ROLLBACK for task MSMCJTSK failed, SQLCODE=-120, SQLSTATE=51003, RETCODE=, IRETCODE=X'0000'  
MSMC0503E SQL error message: PROGRAM TIMESTAMP 374699744 NOT = PLAN TIMESTAMP 319477894                    

 

Environment:  

Any supported release of z/OS.

Release r14.1 of CA Common Services with release upgrade performed of the Software Configuration Service (SCS).

 

Cause: 

There is a mismatch between the CA Datacom/MSM SQL plans delivered in the CA Common Services CAW0EXP data set and those defined in the CA CSM Datacom database.

The new plans must be imported into the CA CSM Datacom database for this release of the Software Configuration Service (SCS).

 

Resolution:

Run job MSMCXPLN located in the CA Common Services CAW0JCL data set. You will need to run it 3 times pointing to members MSMCCSQL,
MSMCFSQL, and MSMCISQL in CAW0EXP.
 

 

Environment

Release: MSMNGR00200-5.1-Chorus Software Manager
Component: