PAM Access Page Columns Missing in Web Browser
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PAM Access Page Columns Missing in Web Browser

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Article ID: 416888

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When accessing different PAM appliances in a web browser, it is observed that some columns in the Access page were missing on a few of the appliances. This behavior was not observed in the past.

For the production appliances, the Access page looks as in the screenshot below.

 

But for non-production appliances, they have the Access Methods and Services columns which are not present in production.

Environment

Privileged Access Manager 4.2 and above

Cause

PAM introduced the RDP Gateway in the 4.2.0 release, followed by the SSH Gateway in the 4.2.1 release. These features allow RDP and SSH sessions through the web browser, which were not previously possible in previous versions. As mentioned in the note on the Use the Access Page for the Web Browsers documentation page, the Access Methods and Services columns will not be loaded on the Access page if neither of these features are enabled.

In this case the RDP Gateway was configured in the non-production environment, but was not yet configured in production.

Resolution

Refer to either the Configure the PAM Gateway for RDP or Configure the PAM Gateway for SSH for instructions to configure these features. Once they have been configured in both environments, the Access pages will match.