SpectroSERVER will not start and shows "database version is unavailable"
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SpectroSERVER will not start and shows "database version is unavailable"

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Article ID: 416874

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

When the SpectroSERVER is started the following error shows and it is shut down:

The SpectroSERVER is running version X but the database version is unavailable

The SpectroSERVER and the database must have the same version number to be compatible.  Please load a X version of the database.

$SPECROOT/SS/SpectroSERVER has successfully shut down.

Cause

Running the database load command from another directory other than the SS

Resolution

The SpectroSERVER database save and load commands must be run from the SS directory and utilize the commands from the SS-Tools directory as your Spectrum installation owner. To determine the Spectrum install owner, you can review the $SPECROOT/SS/.vnmrc file and look for this entry:

initial_user_model_name=

As that user verify you are in the $SPECROOT/SS directory.  Verify your savefile is unzipped.

Run SSdbload:   ../SS-Tools/SSdbload -il ../SS-DB-Backup/db_save_file1.SSdb

If you are on a secondary you may need to replace the hostname of the secondary SpectroSERVER entry that is stamped into the SS database:

Run SSdbload:   ../SS-Tools/SSdbload -ilr 20 ../SS-DB-Backup/db_save_file_from_primarySS.SSdb

You can then save the SSdb to verify the version:

Run SSdbsave:   ../SS-Tools/SSdbsave -cm ../SS-DB-Backup/db_save_file2.SSdb