Attempting to migrate ESXi Host management from a Distributed vSwitch to Standard vSwitch when using LACP/LAG fails with "An error occurred while communicating with the remote Host" and rollback occurs
search cancel

Attempting to migrate ESXi Host management from a Distributed vSwitch to Standard vSwitch when using LACP/LAG fails with "An error occurred while communicating with the remote Host" and rollback occurs

book

Article ID: 416840

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to migrate the management vmkernel from a Distributed vSwitch (vDS) using a LAG/LACP to a Standard vSwitch (vSS) there is an error and the process rolls back the management vmkernel to the vDS.  The error pops up explaining the task created a disconnection and is rolled back to avoid the same.

Environment

VMware vSphere ESXi

Cause

One of the vmnics/Uplinks is taken from the LAG providing the network for the vDS the Host management vmkernel is running on.  The configuration of the physical switch port is not changed from LACP bundled to trunk.  This will cause network connectivity issues when performing the migration of management from a vDS to a vSS.  The process will do the migration, then check to make sure that network connectivity is not lost to the Host.  Since this check sees that connectivity is lost during the migration process, it will roll back to avoid connectivity issues.

Resolution

Prior to migrating the management vmkernel, either the LAG needs to be "broken" or unconfigured, or the physical switch port that the vmnic that is removed from the LAG and added to the vSS needs to be reconfigured to a trunk port.

Additional Information

The below articles can be helpful

Configuring a LAG on a vSphere Distributed Switch Port Group when using LACP

Host requirements for link aggregation (etherchannel, port channel, or LACP) in ESXi