Disconnected from host. Reason: License expired
search cancel

Disconnected from host. Reason: License expired

book

Article ID: 416814

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The following alert was observed on several ESXi hosts in the environment: “Disconnected from host. Reason: License expired.”

  • As a result, the affected hosts appeared as disconnected in vCenter Server.

Environment

  • VMware vSphere 7.x
  • VMware vSphere 8.x

Cause

  • This issue occurs because the ESXi hosts were operating with expired evaluation licenses. Once the evaluation period expires, the hosts lose their license entitlement, leading to disconnection from vCenter Server.
  • This issue will occurs even when the vCenter Server license expires, causing the ESXi hosts to appear in a disconnected state within vCenter Server.

Resolution

  • When you purchase, split, or merge license keys in the Broadcom Support Portal, you must use the new keys to license assets in your vSphere environment. You must go to the vSphere Client and create a license object for every license key. 
  • If the license keys are available on the Broadcom Support Portal but do not match the required version, refer to. Refer to Upgrade and Downgrade VMware License Keys via the Broadcom support portal.
  • To create a new license in the vSphere Client,
    • Click Menu > Administration.
    • Expand Licensing and click Licenses.
    • On the Licenses tab, click ADD.
    • On the Enter licenses keys page, enter one license key per line, and click Next.
      The license key is a 25-symbol string of letters and digits in the format #####-#####-#####-#####-#####. You can enter a list of keys in one operation. A new license will be created for every license key that you enter.
    • On the Edit license names page, rename the new licenses as appropriate and click Next.
    • On the Ready to complete page, review the new licenses and click Finish.
  • To assign a license key to an ESXi host or vCenter Server in the vSphere Client:
    • Log in to vCenter Server using the vSphere Client.
    • In the vSphere Client, navigate to the host in the vSphere inventory.
    • Click on the component you want to assign license to and select the Configure tab.
    • Under System, select Licensing.
    • Click ASSIGN LICENSE.
    • In the dropdown menu, select EXISTING LICENSE on the license keys that already exist in the inventory of the vCenter Server instance that manages the host. Ensure to select a license key that supports all the features that the host runs.
    • Click OK
  • Re-connect the ESXi host to the vCenter
    • Right click on the ESXi from the Inventory.
    •  Under "Connection" option choose "Connect"

Additional Information