IGA Xpress: "Failed to connect to bus: No such file or directory" during install
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IGA Xpress: "Failed to connect to bus: No such file or directory" during install

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Article ID: 416800

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Updated On:

Products

CA Identity Suite

Issue/Introduction

When trying to install v15 on a new system, you see the following:

[INFO] Please use "igx" user to login

Attempting to start/restart/check status fails:
[igx@strongbad-test ~]$ igactl start xpress
Failed to connect to bus: No such file or directory

Environment

Identity Suite v15
Linux RHEL 9.3

Cause

With v15, the client uses and manages their own supported OS for the Identity Suite deployment.  The client may require unique security and permissions for the system.  In this case, the system had locked out registering new created user sessions. When trying to generate and register the igx user which is required to install v15, the install would immediate stop with the error discussed here. The required setting below allows the session to be registered and install to complete. 

 

Resolution

Add: "session required pam_systemd.so" to /etc/pam.d/login

#%PAM-1.0
auth       substack     system-auth
auth       include      postlogin
account    required     pam_nologin.so
account    include      system-auth
password   include      system-auth
# pam_selinux.so close should be the first session rule
session    required     pam_selinux.so close
session    required     pam_loginuid.so
# pam_selinux.so open should only be followed by sessions to be executed in the user context
session    required     pam_selinux.so open
session    required     pam_namespace.so
session    optional     pam_keyinit.so force revoke
session    include      system-auth
session    include      postlogin
-session   optional     pam_ck_connector.so
session    required     pam_systemd.so

Additional Information

pam_systemd.so