Problem:
The following error appears in the install.log when upgrading CA Service Management database from 12.7 to 14.1:
[InstallCDB] Failed to create mdbadmin user (mdbadmin) for Database Name (mdb) in (<Hostname>) Database.
2016/04/20 15.37.00.257 ERROR [DeployThread: Common tables configuration of CA Service Management] [InstallCDB] Creation of mdbadmin user failed.
java.lang.Exception: Creating mdbadmin user failed.
at com.ca.smsi.installui.tasks.InstallCDB.createUser(InstallCDB.java:299)
at com.ca.smsi.installui.tasks.InstallCDB.installDatabase(InstallCDB.java:196)
at com.ca.smsi.installui.tasks.InstallCDB.run(InstallCDB.java:44)
at com.ca.smsi.wizard.task.Task.start(Task.java:222)
at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:455)
2016/04/20 15.37.00.272 DEBUG [DeployThread: Common tables configuration of CA Service Management] [ProgressPage] ProgressPage - Task Changed Configuración de las tablas comunes de CA Service Management
2016/04/20 15.37.00.272 DEBUG [DeployThread: Common tables configuration of CA Service Management] [ProgressPage] Task State Changed. TaskID: task.install_CDB, Common tables configuration of CA Service Management, Old State: running, New State:failed
2016/04/20 15.37.00.272 DEBUG [DeployThread: Common tables configuration of CA Service Management] [ProgressPage] ProgressPage - Task Error.
Environment:
Microsoft SQL Server - All supported versions
Cause:
The SQL Server user being used to upgrade the database does not have the necessary privileges to complete upgrade successfully.
Resolution:
1) Log into SQL Server instance where mdb database is located.
2) Ensure the SQL Server user being used to upgrade the database has the following privileges:
3) Run the upgrade again.
Additional Information:
Further details regarding the database user privileges:
http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec617177.aspx