Aria Operations and Operations for Logs sending large number of Envoy requests to vCenter
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Aria Operations and Operations for Logs sending large number of Envoy requests to vCenter

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Article ID: 416672

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

 Aria Operations was observed sending request in large numbers for connection requests to a vCenter server.

Below is an example of the log snippet indicating connection failures to vCenter on port 443:
  • com.vmware.vim.vmomi.client.exception.TransportProtocolException
  • org.apache.http.NoHttpResponseException
Two certificates were found, a default SSL certificate (not expired) and custom SSL certificate expiring which caused the connection issues and led to the excessive envoy requests.

 

Environment

Aria Operations for Logs 8.18.x
Aria Operations 8.18.x

Cause

High volume of API requests causes the vCenter UI to crash intermittently, necessitating frequent restarts of the envoy service as a temporary workaround.
Misconfiguration in the Aria Operations truststore was observed where multiple active vCenter SSL certificates were present for the vCenter adapter. 

Resolution

Issue occurs due to any expired vCenter certificates present in Aria Operations trust store.

  • Delete the problematic vCenter certificates from "Trusted Certificates" section within Aria Operations.
  • Delete vCenter adapter from Aria Operations (with a specific note to not delete related objects).
  • The vCenter adapter has to be re-added using [email protected].

After these steps, the correct certificate will be added in Aria Operations trust store, which will eliminate the high number of envoy requests.