Aria VMware Catalog items are being pulled into ServiceNow with empty Catalog Client Scripts
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Aria VMware Catalog items are being pulled into ServiceNow with empty Catalog Client Scripts

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Article ID: 416659

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

After updating to the ServiceNow Zurich release, Aria Automation Catalog items are being pulled into ServiceNow with empty Catalog Client Scripts 

Environment

  • Aria Automation 8.18.1
  • ServiceNow Zurich

Cause

In The Zurich update, there is a change in the way scripts are imported by ServiceNow, which require additional permissions

Resolution

 Add the "snc_required_script_writer_permission" role to get the scripts to pull in again:

  1. Login with system administrator
  2. Navigate to sys_user_role table
  3. Open "admin" record
  4. In "Contains roles" section, edit it to add "snc_required_script_writer_permission" role and save it.