Host went not responding state in vCenter but is up and running in console
search cancel

Host went not responding state in vCenter but is up and running in console

book

Article ID: 416633

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Host with running VMs became "Not responding" in vCenter UI.
VMs running on the host are unaffected.
When logging into the host out of band management console (iLO, iDRAC, BMC, etc), or the direct host client, the host appears to be operating normally and is fully responsive.
Stopping and restarting hostd and vpxa services on the host does not resolve the situation.
Resetting the management network on the host does not resolve the situation.

Environment

ESXi managed by vCenter

Cause

The issue occurs when the vCenter created vpxuser password is out of sync with the vCenter Server database and the password on the host or when the password is manually modified.

Note: VMware does not recommend modifying the vpxuser account.

Resolution

Resynchronize the password with the vCenter Server database.
 
Note: Do not remove the host from the Inventory. When an ESX/ESXi host is removed from the vCenter Server Inventory, virtual machines are removed from their respective folders, performance data for the host is lost, and any Distributed Virtual Switch configurations on the host will need to be reconfigured.
 
To resynchronize the password with the vCenter Server database:

  • Disconnect the ESXi host from vCenter's inventory
    • From the vCenter UI, navigate to Home > Hosts and Clusters and select a host.
    • Right-click the host and select Connection > Disconnect from the pop-up menu.
    • In the confirmation dialog box that appears, click Ok.
      • If the managed host is disconnected, the word “disconnected” is appended to the object name in parentheses, and the object is dimmed. All associated virtual machines are similarly dimmed and labeled.
  • Reconnect the host and enter the root password when prompted.
    • From the vCenter UI, navigate to Home > Hosts and Clusters and select a host.
    • Right-click the host and select Connection > Connect from the pop-up menu.
      • When the managed host’s connection status to vCenter Server is changed, the statuses of the virtual machines on that managed host are updated to reflect the change
    • After the host is successfully reconnected to vCenter Server, its associated virtual machines are automatically restored. In the VMs and Templates view, these VMs are placed into a default folder, which may not reflect their original organizational structure. Simultaneously, in the Hosts and Clusters view, the virtual machines reappear under the host to which they are registered.

To maintain consistency and ensure proper management, it's recommended to manually reorganize the virtual machines into their intended folders within the VMs and Templates view. This helps preserve logical grouping, simplifies navigation, and aligns with operational standards.

If the issue persists, refer to Reconnecting a host to vCenter Server fails with the error: Rejected password for user vpxuser.

Additional Information

Disconnecting and Reconnecting an ESXi Host

Similar issue Host Summary page reports "Cannot synchronize host" or "Quick stats on <Hostname> is not up-to-date"