Unable to converge SRM and VR appliances to new version appliance.
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Unable to converge SRM and VR appliances to new version appliance.

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Article ID: 416628

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

You are unable to converge SRM and VR appliances to a new VLSR appliance 9.0.4.

When you start the convergence workflow, you notice a stale vSAN Data Protection service from a previous attempt to converge.

 

Environment

VLSR 9.0.4

Cause

The unsupported version of vSAN Data Protection is preventing the workflow to continue, even though you do not have a vSAN Data Protection appliance on your environment.

Resolution

Delete vCenter lookup service registrations related to the not present appliance (xxx.vlr010.xxx in this case).

  • Run lstools.py list on vCenter server ssh (/usr/lib/vmidentity/tools/scripts/lstool.py list as described at Process to view the List of Services Registered with Single Sign-On ).
  • Search for service registrations where URL matches the stale entry (xxx.vlr010.xxx in this case) and copy the corresponding Service ID
  • Navigate to https://<vCenter_Server_address>/lookupservice/mob/?moid=ServiceRegistration&method=Delete ( as described at Clean up the vCenter Lookup Service ).
  • To delete the service registration, enter the serviceId value and click Invoke Method.