No key input is accepted on the DCUI and ESXi gets into a hang up condition
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No key input is accepted on the DCUI and ESXi gets into a hang up condition

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Article ID: 416551

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Updated On:

Products

VMware vSphere ESX 8.x VMware vSphere ESX 7.x

Issue/Introduction

An ESXi host becomes unresponsive with the following symptoms:

  • An ESXi host is designated as "Not Responding" in vCenter (i.e. the vSphere Client)
  • Unable to connect to the ESXi host via SSH. However, the host remains responsive to pings.
  • Key input on the Direct Console User Interface (DCUI) is not accepted.
  • While the ALT+F1 key functions, login attempts on the console are unsuccessful.
  • Logging for services on the ESXi host stops.

Environment

VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

These symptoms may be caused by the service 'vmsyslogd' hanging.

Resolution

This is a known issue, which is fixed in ESXi 7.0 U3v and ESXi 8.0 U3e.

Additional Information

If the known bug is already addressed, but the DCUI hang symptom is still observed, please collect a VMKernel memory dump and DCUI memory dump by following the steps below:

  1. When the DCUI and the system are running normally, set the following parameter on the ESXi shell, so that DCUI memory dump is included when VMKernel memory dump is generated:
    # vsish -e get /userworld/cartel/<PID of dcui>/debug/dumpOnKernelPanic
  2. When the hang-up symptom is observed, send a NMI from the BMC (ex. iLO, iDRAC, etc) to make the system panic and generate a VMKernel memory dump.
  3. After the reboot, collect a vm-support log bundle and open a case with Broadcom Support for further investigation.