vIDB Deployment fails at Stage 6 in Fleet Management
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vIDB Deployment fails at Stage 6 in Fleet Management

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Article ID: 416518

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Updated On:

Products

VCF Operations

Issue/Introduction

  • The vIDB deployment stalls at Stage 6 in Fleet Management with the error "LCMVIDB0002 – No failed pods found"
  • vmsp pkg push operation times out with "Error: context deadline exceeded" although the capture error scripts report "No failed pods found"
  • Attempts to generate log bundles fail with an "HTTP error 401 (unauthorized)" indicating an issue with authentication.

Environment

VCF 9.0.x.0

Cause

Default admin@local account for the LCM (Fleet Management) appliance is locked out, preventing proper authentication and communication, which in turn causes log bundle generation to fail and likely interfere with the vIDB deployment process completing successfully and reporting its status.

Resolution

Reset the admin@local password with below steps:
  • SSH to LCM appliance and run the below command:
    • touch /var/lib/vrlcm/ENABLE_PWD_RETRIEVAL
    • /opt/vmware/share/vami/vami-vlcm-passwd-reset to set a new password.
  • Once password is set, delete the file - /var/lib/vrlcm/ENABLE_PWD_RETRIEVAL
Note: Recommended approach for the password reset is from the fleet management UI.

Additional Information

Refer: