Compatibility issues between VMware Tools 13.1.0 (and later) and Horizon View 7.8 (and earlier) when used on Windows VMs
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Compatibility issues between VMware Tools 13.1.0 (and later) and Horizon View 7.8 (and earlier) when used on Windows VMs

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Article ID: 416513

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

A black screen may be observed on connecting to a Windows VM using Horizon View 7.8 or earlier with VMware Tools 13.1.0 or later installed.

Environment

VMware Tools 13.1.0 and later installed on a Windows VM running Horizon View 7.8 and earlier.

Cause

  • Starting with VMware Tools 13.1.0 or later, the installer no longer checks Horizon View compatibility for the SVGA driver.
  • In prior versions of VMware Tools, the installer would skip the SVGA driver installation if Horizon View 7.8 or earlier was detected on the system.

Resolution

Choose one of the following to resolve the compatibility issue:

  1. Upgrade to Horizon View 7.9 and later to use the latest SVGA driver.

    OR

  2. Install VMware Tools 13.1.0 using the custom setup and deselect the SVGA driver to continue using Horizon View 7.8 and earlier.

    OR

  3. Silently install all features except the SVGA driver for VMTools 13.1.0 by running the command below :

    setup.exe /S /V “/qn ADDLOCAL=ALL REMOVE=SVGA REBOOT=R”

    Note: Adjust parameters as needed for your deployment.