Aria Operations and Aria Operations for Logs may send a large number of Envoy connection requests to vCenter Server
search cancel

Aria Operations and Aria Operations for Logs may send a large number of Envoy connection requests to vCenter Server

book

Article ID: 416475

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Aria Operations and Aria Operations for Logs may send a large number of Envoy connection requests to vCenter Server.
This behavior can cause vCenter UI instability, including intermittent crashes and the need to restart the Envoy service multiple times as a temporary workaround.

Environment

Aria Operations 8.18.x
Aria Operations for Logs 8.18.x
vCenter Server: Any version integrated with the above Aria Operations instance

Cause

The issue occurs when multiple active vCenter certificates are present in the Aria Operations truststore.
As a result, Aria Operations repeatedly attempts to establish new Envoy connections to vCenter using all trusted certificates, leading to an excessive number of connection requests.
 
This behavior can overwhelm the vCenter Envoy service, causing intermittent UI crashes.

Resolution

To resolve the issue, remove duplicate or invalid vCenter certificates and re-add the vCenter adapter to Aria Operations.
 
Steps:
  • Access Aria Operations UI.

  • Log in as an local user "admin".

  • Remove the duplicate vCenter certificates.

  • Navigate to:

Administration → Certificates → Trusted Certificates

  • Identify and delete all vCenter certificates related to the problematic vCenter Server.

  • Delete the vCenter Adapter instance.

  • Go to: Administration → Solutions → vCenter Adapter

  • Select the vCenter adapter and click Delete.

  • Important: Do not select the “Delete Related Objects” checkbox when prompted.

  • Re-add the vCenter Adapter.

  • Reconfigure the vCenter adapter connection.

  • When prompted, accept and add the correct vCenter certificate to the Aria Operations truststore.

  • Validate the connection.

  • Ensure the adapter status shows "Data receiving".

  • Monitor the vCenter Envoy logs — the number of connection requests from Aria Operations should now stabilize.

Result:
 
Once the correct certificate is added to the Aria Operations truststore, Envoy will no longer receive a high volume of connection requests, and vCenter UI performance will stabilize.

Additional Information

Ensure that only one valid vCenter certificate exists in the Aria Operations truststore.
If multiple Aria components connect to the same vCenter, ensure all use the same, valid certificate.
Restarting the Envoy service should no longer be necessary once the configuration is corrected.