Aria proxy failed to connect to VMware Cloud Foundation Operations after new deployment
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Aria proxy failed to connect to VMware Cloud Foundation Operations after new deployment

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Article ID: 416466

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Updated On:

Products

VCF Operations

Issue/Introduction

  • After a new cloud proxy was deployed from ova following documentation - Configuring Cloud Proxies in VCF Operations, it is not connecting
  • In the console, the error is seen:

    "Failed to connect to VMware Cloud Foundation Operations after 30 retries"

  • Running cprc-cli -d -v from the Cloud Proxy after logging in as root shows:

    DNS analysis:
    "Network is unreachable"  - DNS server could not be pinged

    ping <IP_of_Cloud_Proxy>
    Network is unreachable

    "vROps on-prem IP(s) resolution begin...
    FAILED to resolve

    Default gateway analysis
    GATEWAY default : UNKNOWN

  • The cloud proxy hostname is showing as localhost
  • /opt/vmware/etc/ovfEnv.xml file and /etc/systemd/network/10-eth0.network show the default gateway as expected.

Environment

VCF Operations 9.x

Cause

An incorrect subnet mask was entered when deploying the OVA in vCenter

Resolution

  • It would be best to redeploy the Cloud Proxy and enter the correct subnet mask
  • Another option would be to edit environment settings for the Cloud Proxy from Configure > vApp Options in vCenter after powering off then enter the proper subnet mask or any other incorrect value
  • If the hostname is still set to localhost after powering on:
    • Update the hostname by running this command as root from the console:

              $VMWARE_PYTHON_BIN /usr/lib/vmware-vcopssuite/utilities/bin/sethostname.py NewHostName

              Where NewHostName is the hostname you want to use.

    • Restart the Cloud Proxy from vCenter.

      Note: If the hostname fails to update after a restart or it still does not show proper connection to VMware Cloud Foundation Operations, proceed to redeploy the Cloud Proxy with the proper network values