Usage Meter in 'Unknown' status in the VCF Business Services Console.
search cancel

Usage Meter in 'Unknown' status in the VCF Business Services Console.

book

Article ID: 416304

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

An unexpected state 'Unknown' of Usage Meter appliance is being displayed within the VCF Business Services Console.

  • 'Unknown' status in VCF Business service console.
  • Successfully sends data using "Send update to CPN". However, Usage Meter version do not update to the latest version 9.0 after upgrade in VCF Business Services Console.
  • DSS logs report failure to prepare files.
http-vcloudusage start-data-storage-service.sh[####]: ####### ERROR --- [TaskScheduler-##] c.v.um.dss.uploader.UploaderService : Failed to prepare files for uploading
http-vcloudusage start-data-storage-service.sh[####]: java.nio.file.AccessDeniedException: /opt/vmware/umdata?

Environment

Usage Meter 9.x

Cause

Due to the missing directory of umdata in the path /opt/vmware, Usage Meter fails to upload data to the VCF Business service console.

Resolution

Follow steps to create missing directory and update the required permissions.

  1. Change directory to /opt/vmware
    cd /opt/vmware

  2. Create a new directory umdata
    mkdir umdata

  3. Update permission of the created directory
    chown -R usagemeter:umdata /opt/vmware/umdata

  4. Reboot the appliance.

Additional Information

Note: Screenshot has version 4.0 as this is generic version for newly registered UMs before they send any data to the cloud.