Getting messages IEC161I , CAG8001E and IEC340I when running Easytrieve Plus Report Generator
search cancel

Getting messages IEC161I , CAG8001E and IEC340I when running Easytrieve Plus Report Generator

book

Article ID: 416243

calendar_today

Updated On:

Products

Easytrieve Report Generator

Issue/Introduction

Getting messages:

IEC161I 072-053 <job>,<step>,<ddname>,<dev,ser>,<xxx>,<dsname>,<cat>

CAG8001E CAN NOT OBTAIN WORK AREA. BYPASSING API.                 
IEC340I - IGC0002F, INSUFFICIENT STORAGE FOR THE CATALOG WORKAREA 

IEC161I 037-002 <job>,<step>,<ddname>,<dev,ser>,<xxx>,<dsname>,<cat>

Then the step fails.

Environment

z/os

Easytrieve Report Generator 11.6

 

Cause

The file in message IEC161I is empty.  The IEC161I messages indicate this.  The CAG8001E messages will only happen if CA1 is install and active.

The Easytrieve option MTVSERR is set to Y.

Resolution

Set the option MTVSERR to N. This will allow Easytrieve to successfully run even if a VSAM file is empty.