VMware NSX Edge status stuck in "Pending Registration" post failed upgrade or rollback
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VMware NSX Edge status stuck in "Pending Registration" post failed upgrade or rollback

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Article ID: 416241

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Updated On:

Products

VMware NSX

Issue/Introduction

  • In the NSX Manager UI, navigating to System > Fabric > Nodes > Edge Transport Nodes shows an NSX Edge node stuck in a "Pending Registration" state.

  • This state occurs after the Edge is redeployed following a failed upgrade or an upgrade rollback.

  • When verifying the cluster via CLI, you observe that the affected NSX Edge node is running a newer version than the NSX Manager.

Environment

VMware NSX

Cause

After an upgrade rollback, the NSX Edges might remain on a higher version than the NSX Manager.
In this scenario, the NSX Manager does not have the newer version of the Edges in its whitelist and will refuse to register them.

Resolution

Workaround:

Replace the faulty NSX Edge with a newly deployed Edge that matches the expected version.

  1. Deploy a new NSX Edge node and configure it manually.

  2. Replace the faulty Edge with the newly deployed Edge within the Edge Cluster.

  3. If the replace operation fails, delete the old NSX Edge and attach the newly deployed edge to the Edge Cluster.

Additional Information

If you believe you have encountered this issue, and the workaround above did not resolve the problem, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.