Web console for VMs remains in a 'Connecting' state for a prolonged period in VMware Cloud Director
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Web console for VMs remains in a 'Connecting' state for a prolonged period in VMware Cloud Director

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Article ID: 416182

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When attempting to open the web console for VMs in VMware Cloud Director UI, the console remains in a 'Connecting' state for a prolonged period and eventually fails to open.
  • The consoles of the affected VMs can be accessed successfully from vCenter directly.

  • The /opt/vmware/vcloud-director/logs/console-proxy.log, reports the following error

    Date-Timestamp  | ERROR | pool-jetty-##### | ServerWebSocket | Connecting to ESX ####.####.com [server: ########]] [client: not-connected] |########]] [client: not-connected] |
    Date-Timestamp  | DEBUG | pool-jetty-##### | ServerWebSocket | onClose: status=1, 011, reason=vmware internal error 04 [server[########] ] [client: not-connected] |

  • A ping test from the VMware Cloud Director cell to the affected ESXi host fails

 

Environment

VMware Cloud Director 10.6.1

Cause

The issue occurs because the network connection between the VMware Cloud Director cell and the ESXi host where the VM resides is unreachable.

Resolution

To Resolve this issue, check with the internal networking team to identify and resolve any network, routing, or firewall issues that were blocking communication.

After the connectivity between the VMware Cloud Director and the ESXi host is restored, the VM web console starts functioning as expected.