V2V Migration Fails with Error 'Unsupported version URI' After Upgrading to VMware vCenter Converter
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V2V Migration Fails with Error 'Unsupported version URI' After Upgrading to VMware vCenter Converter

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Article ID: 416092

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Updated On:

Products

Converter

Issue/Introduction

  • Attempting to connect to a source machine using VMware vCenter Converter, the operation fails immediately after accepting an expired certificate warning. The following error message is displayed,

    "A general system error occurred: Unsupported version URI "urn:converter/6.6" while parsing SOAP body at line 6, column 0 while parsing SOAP envelope at line 2, column 0 while parsing HTTP request before method was
    determined at line 1, column 0"



  • Reviewing the log file in client machine "\Users\%USERPROFILE%\AppData\Local\VMware\VMware vCenter Converter Standalone Client\Logs\vmware-converter-worker.log" indicates that the connection failed due to an expired certificate.

    YYYY-MM-DD:T:HH:MM:SS warning vmware-converter-worker[#####] [Originator@### sub=IO.Connection] Failed to SSL handshake; SSL(<io_obj t:class Vmacore::System::TCPSocketObjectAsio, h:####, <TCP '<Client machine IP> : 50259'>, <TCP '<Source machine IP> : ####'>>), e: ########(certificate verify failed (SSL routines)), duration: SS
    YYYY-MM-DD:T:HH:MM:SS warning vmware-converter-worker[#####] [Originator@#### sub=HttpConnectionPool-#####] Failed to get pooled connection
    ; <cs p:#######, TCP:'Source machine FQDN':9089>, SSL(<io_obj t:class Vmacore::System::TCPSocketObjectAsio, h:1516, <TCP '<Client machine IP> : #####'>, <TCP '<Source machine IP> : ####'>>), duration: ##msec, class Vmacore::Ssl::SSLVerifyException(SSL Exception: Verification parameters:
    --> PeerThumbprint: ##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##

  • This error is seen post upgrading VMware vCenter convertor standalone on the same client machine.

Environment

VMware vCenter Converter Standalone

Cause

This issue occurs due to a stale Convertor agent being present on the source machine (to be converted) from previous installation.

Resolution

The stale convertor agent needs to be removed from the source machine before retrying conversion.

For Windows machine :

  1. Login into source machine with Administrative privilege
  2. Go to run and enter appwiz.cpl 
  3. Click on VMware convertor from program and uninstall
  4. Login to the client machine and reattempt the VM conversion

Note :- The reattempt to convert would automatically install the valid convertor agent