Unable to retrieve data from servers
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Unable to retrieve data from servers

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Article ID: 416080

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Updated On:

Products

Protection Engine for NAS

Issue/Introduction

After installing SPE 9.3 and adding the server to the SPE 9.3 console, you notice an inability to connect to the SPE server.

The below error is shown on the SPE console:

You also see entries similar to the following in the CmafUI.log: 

2025-10-27 06:48:06,446 [17] ERROR Symantec.Cmaf.Security.AuthManagerHelper - Exception is caught while executing ExecuteAuthenticateRestApi. Reason: Unable to execute authentication rest api.. Reason: No message available
2025-10-27 06:48:06,446 [17] ERROR Symantec.Cmaf.Security.BasicAuthManager - Exception is caught while getting token for server: <SERVER_NAME/IP>. Reason: No message available

Environment

SPE 9.x

Cause

The sperestapi.auth.enabled setting is set to false.

Resolution

To resolve this issue, follow the steps listed below:

  1. Connect to the SPE and navigate to <SPE_INSTALL_FOLDER>/RestAPI
  2. Run the following command:
    • Windows:
      restconfigmodifier.exe -update sperestapi.auth.enabled true application.properties
    • Linux:
      ./restconfigmodifier -update sperestapi.auth.enabled true application.properties
  3. Restart the SPE RestAPI service
    • Windows:
      net stop symcrestapiservice
      net start symcrestapiservice
    • Linux:
      /etc/init.d/symcrestapiservice restart