Unable to add SPE to the console
search cancel

Unable to add SPE to the console

book

Article ID: 416060

calendar_today

Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

Attempting to add a Symantec Protection Engine (SPE) to the SPE Console results in the following error:

Failed to add the following server(s):
<SERVER_NAME/IP> Reason: No message available

 

You also see entries similar to the following in the CmafUI.log

2025-10-28 06:37:59,470 [Main UI Thread] ERROR Symantec.Cmaf.Security.AuthManager - Exception is caught while adding server: <SERVER_NAME/IP>. Reason: No message available
...
2025-10-28 06:46:45,844 [Main UI Thread] INFO  Symantec.Cmaf.Security.RestResponseErrorHelper - Parsing the error Response string:<Map><timestamp>2025-10-28T13:46:45.657+00:00</timestamp><status>404</status><error>Not Found</error><message>No message available</message><path>/v1/authentication</path></Map>

Environment

SPE 9.x

Cause

The sperestapi.auth.enabled setting is set to false.

Resolution

To resolve this issue, follow the steps listed below:

  1. Connect to the SPE and navigate to <SPE_INSTALL_FOLDER>/RestAPI
  2. Run the following command:
    • Windows:
      restconfigmodifier.exe -update sperestapi.auth.enabled true application.properties
    • Linux:
      ./restconfigmodifier -update sperestapi.auth.enabled true application.properties
  3. Restart the SPE RestAPI service
    • Windows:
      net stop symcrestapiservice
      net start symcrestapiservice
    • Linux:
      /etc/init.d/symcrestapiservice restart