スワップ領域不足により、vCenter のサービス健全性が断続的に緑から赤に変化する
search cancel

スワップ領域不足により、vCenter のサービス健全性が断続的に緑から赤に変化する

book

Article ID: 416025

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項:これは英文記事「Health status of some vCenter services intermittently changes from green to red due to insufficient swap space」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • vCenter の sts や sps、vsphere-ui などの サービス健全性が、緑から赤へ、そしてまた緑へと断続的に変化します。"(サービス名) status changed from green to red" という SNMP トラップを受信する場合があります。
  • sts や sps、vsphere-ui は停止している場合があります。サービス稼働状況を確認するには、service-control --status --all を実行してください。
  • vSphere Client が一時的に利用できません。
  • サービス健全性が赤に変化した時間帯に、Java のログファイルが作成されています。
    • Java ログファイルへのパスは以下の通りです。
      • sts : /storage/log/vmware/sso/hs_err_stsinstaller_pid(pid 番号).log
      • sps : /storage/log/vmware/vmware-sps/java_error(pid 番号).log
      • vsphere-ui : /storage/log/vmware/vsphere-ui/java_error(pid 番号).log
    • Java ログファイルの作成日時を確認するには、ls コマンドを使用してファイルの最終更新日時を確認してください。例 :
      # ls -l /storage/log/vmware/sso/hs_err_stsinstaller_pid280848.log
      -rw-r--r-- 1 sts lwis 58998 Oct 15 04:15 /storage/log/vmware/sso/hs_err_stsinstaller_pid280848.log
  • スワップの使用率が高くなっています。確認するためには、free を実行してください。
    # free
                   total        used        free      shared  buff/cache   available
    Mem:        21497432    13963404      178428      696824     7355600     6445128
    Swap:       26206204    24614768     1591436 <<< 約 94% 使用済み

Environment

VMware vCenter 8.0 U2a 以降

Cause

スワップ領域不足により、サービスの Java スレッドが停止します。
vc-ws1a-broker にはメモリリークを引き起こす既知の問題があり、それによりスワップ領域が枯渇します。詳細については、以下の KB 396939 をご参照ください。
vCenter services experiencing OutOfMemoryError: Java heap space, causing the swap memory to be 100% utilized and due to which vCenter backup fails with " Error: database or disk is full".

Resolution

vc-ws1a-broker の再起動により、事象は一時的に解消します。
# service-control --restart vc-ws1a-broker
: vc-ws1a-broker の再起動は、 Azure AD や Okta などの外部 IDP を利用した認証に影響します。

事象の再発を防ぐには、KB 396939 の Resolution セクションに従ってください。