SSP backup process remains stuck in "In Progress" state for an extended duration, ultimately resulting in an operation timeout
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SSP backup process remains stuck in "In Progress" state for an extended duration, ultimately resulting in an operation timeout

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Article ID: 416023

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

When you try to take backup, backup job pod is terminated with error state or when you try to update backup server configuration then cluster-api pod is restarted without any error.


When attempting to take a backup:

  • The backup job pod terminates or restarts before backup progress begins.

  • No explicit error appears in logs or UI.

  • Updating the backup server configuration causes the cluster-api pod to restart.

  • In some cases, a “503 Service Unavailable” error may appear when you initiate a backup.

Environment

SSP 5.0 and  SSP  5.1

Cause

The backup job pod and cluster-api pod are restarting when the user attempts to take a backup.

This is likely caused by corrupted data in the BackupConfigInfos table in the Postgres database

The backup job pod logs can be checked by following below steps:

1. SSH into SSPI VM via CLI with root credentials if SSPI version is 5.0 or SSH to SSPI VM CLI via sysadmin credentials if SSPI version is 5.1

2. Execute below commands to get the backup job pod name.

         k get pods -n nsxi-platform | grep -i backup

3. Check backup job pod logs using below command. (Backup job pod name can be copied from above output).

         k logs <backup-job-pod-name> -n nsxi-platform

 

Sample log output: One of pod logs end with below:

 

2025-10-15T08:36:17.145Z INFO status/progress_status_flag.go:27 Request received to update sspBrInProgress flag to: true

2025-10-15T08:36:17.181Z INFO br/backup_handler.go:67 Putting backup status to in_progress state
2025-10-15T08:36:17.218Z INFO br/service.go:165 Backup status post update: {ID:f57145d8-0bdf-4adc-bfde-f91ae4618a61 BackupEndTime:<nil> BackupStartTime:2025-10-15 08:36:10.276343 +0000 UTC LastUpdatedAt:2025-10-15 08:36:17.183588245 +0000 UTC m=+1.418129683 BackupType:FULL_BACKUP BackupTriggerType:MANUAL ErrorMessages:null FileSize:0 Percentage:0 ProgressMessage:Preparing to start backup Status:IN_PROGRESS Version:5.0.0-0.0-24631122 JobName:job-backup-wbcnj Name: Description:}

2025-10-15T08:36:17.218Z INFO br/backup_handler.go:80 Preparing config to start backup

Resolution

Reconfigure backup server by following below steps:

  1. SSH to  SSPI VM via CLI with root credentials if SSPI version is 5.0  or  SSH to SSPI VM CLI via sysadmin credentials if SSPI version is 5.1
  2. Execute the below command from SSPI VM to SSH into postgresql pod:
    # k exec -it postgresql-ha-postgresql-0 -n nsxi-platform -- bash
  3. Login to postgres server using command:
    # PGPASSWORD=$POSTGRES_PASSWORD psql -d clusterapi
  4. Delete backup server configuration using command:
    # delete from backup_config_infos;
  5. Refresh SSP UI and confirm backup configuration deleted.

  6. Configure backup server again from UI.

  7. Now try to take SSP backup.

  8. If issue still persists, contact Broadcom support.