Local Manager Shows Incorrect Version in Global Manager UI After a Successful Upgrade
search cancel

Local Manager Shows Incorrect Version in Global Manager UI After a Successful Upgrade

book

Article ID: 415974

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

After successfully upgrading Local and Global Managers in a federated environment, some locations may still show the old version number for the Local Managers in the Global Manager UI. 

Environment

VMware NSX 4.x

Cause

This can be caused by if the Local Managers at a site are restored from backup, or it can be caused by issues with the order of the Local Manager nodes being upgraded. 

Resolution

To resolve this, SSH to a Local Manager of the affected site as root and run the following API: 

curl -X POST -ik http://localhost:7999/api/v1/sites?action=refresh -H 'X-NSX-Username:admin;adminPassword'

 

 

Additional Information

Kindly refer to the KB article to enable the root access on NSX manager Enable ssh root access for NSX appliances