Virtual machine is suspended due to expiration of runtime lease in spite of setting runtime lease to Never Expires
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Virtual machine is suspended due to expiration of runtime lease in spite of setting runtime lease to Never Expires

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Article ID: 415838

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Virtual machine with a configured storage lease is suspended due to expiration of runtime lease.
  • Tenant vApp shutdown due to lease despite being set to never expire in app settings.
  • Examination of the audit_trail does not show any com/vmware/vcloud/event/vapp/lease_expiration_changed event_type as outlined in Alarm "Stopping vApp XXXX as it has exceeded its runtime lease" is received in Cloud Director
  • Within the Cloud Director log /opt/vmware/vcloud-director/logs/vcloud-container-debug.log you see the following:

yyyy-mm-dd hh:mm:ss,fff | DEBUG    | Backend-activity-pool-714 | VAppCleanUpActivity            | [Activity Execution] Runtime lease has expired for [#### (####] and power action suspend will be applied - Handle: urn:uuid:####, Current Phase: VAppCleanUpActivity$UnDeployExpiredVAppsPhase | activity=(com.vmware.ssdc.backend.VAppCleanUpActivity,urn:uuid:####)

Environment

VMware Cloud Director 10.6.1

Cause

Runtime lease is set based on the storage lease expiry, which is incorrect behavior.

Resolution

Upgrade your environment to VMware Cloud Director 10.6.1.2. This issue is resolved in VMware Cloud Director 10.6.1.2 Build 25088252

You can download VMware Cloud Director 10.6.1.2 from the Broadcom Support Portal.

For earlier versions of VMware Cloud Director see the workaround steps below:

Workaround:
Set storage lease to 'Never Expires' for the impacted vApp(s).

  1. Login to the Tenant portal and navigate 'Applications -> Virtual Applications'.
  2. Click on the impacted vApp.
  3. On the 'General' view click 'EDIT' link under the Lease section.
  4. Within the Lease menu set the storage lease to 'Never Expires'.
  5. Save the change.

Note: If 'Never Expires' does not appear as a choice when trying to implement the workaround then the Organization Administrator should review the policies set as follows:

  1. Within the Tenant portal, the Organization Administrator should navigate to 'Administration -> Settings -> Policies'.
  2. Click the "EDIT" button beside the 'vApp Leases' section.
  3. Change 'Maximum storage lease' to 'Never Expires'.
  4. Save the change to make the lease setting available to Tenant users.

Additional Information

This issue occurs in the following cases:

  • Failure to power off a virtual machine with a storage lease
  • Powering off a virtual machines in vApp consisting of 2 virtual machines