Upgrading vCenter from 7.X to 8.X fails after modifying the openssh version of the appliance
search cancel

Upgrading vCenter from 7.X to 8.X fails after modifying the openssh version of the appliance

book

Article ID: 415802

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

During the first upgrade attempt from 7.X to 8.X the errors are received that match KB Error: "Could not authenticate to source appliance OS on address" when attempting vCenter upgrade but when following the resolution steps from the KB they do not resolve the issue.

A retry is attempted by re-entering the OS password using the same installer, the error from KB: Upgrading vCenter from 7.x to 8.x fails with error "Pre-upgrade check failed due the following problem: Error in method invocation [digital envelope routines] unsupported" is received and the resolution steps again do not resolve the issue.

 

Cause

The vCenters version of OpenSSH has been modified outside of a supported method.

 

As described in KB Vulnerability found for openssh of the vCenter server 

  • Broadcom does not support any modifications or customizations to the underlying operating system and packages included in a VMware-branded virtual appliance.

    This includes adding, updating, or removing of packages, as well as utilizing custom scripts within the operating system of the appliance.  
  • All VMware virtual appliances are thoroughly tested and qualified based on the components and versions included, as well as hardened to the best of the vendors' ability using best practices for the industry. Updating or changing any components may result in unexpected behavior of the system.
  • If security issues are identified to affect a supported Broadcom product, or the operating system of an appliance, Broadcom will release a patch to address the issues.

Resolution

If the issues described in this KB are received, then we recommend opening a case with Broadcom Support to confirm that OpenSSH has been modified outside of a released vCenter update or patch.

  • In situations where an appliance has been modified by the customer, Broadcom reserves the right to request all modifications be reverted and that the issue be reproduced on the base release that was originally provided.

Additional Information