High CPU usage after EPAgent restart
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High CPU usage after EPAgent restart

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Article ID: 415769

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Your observed an unusual behavior with the  EPAgent running on our Layer7 API Gateway (versione 11.0).

After performing a restart of the EPAgent service using the following commands:

systemctl stop epagent

systemctl start epagent

the CPU usage, which is normally stable around 20%, immediately jumps to about 50%.

The CPU then remains at this high level for several days before it gradually decreases back to the previous stable value (~20%).

Cause

EPagent seems running with older out of support release. Also agent is showing some metrics having strange names. 

Resolution

Install the APM 10.8 SP1 APMIA agent which is fully support with APM 10.8 release.
The download and install information is available here:

CA API Gateway

Even thought document is for DX SAAS, but it is also validate for APM 10.8 SP1 APMIA agent. You can download the APM 10.8 SP1 APMIA agent from support portal site:

Broadcom Support