Insufficient disk space. Disk space usage exceeds 95% in '/opt/vmware/heapdump'
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Insufficient disk space. Disk space usage exceeds 95% in '/opt/vmware/heapdump'

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Article ID: 415723

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

root [ /home/admin ]#df -h

/dev/mapper/support_vg-heapdump  3.9G  3.7G     0 100% /opt/vmware/heapdump

root [ /home/admin ]# ls -lha /opt/vmware/heapdump/hms/
total 3.7G
drwxr-x--- 2 vrms vrms 4.0K Oct 13 09:09 .
drwxr-xr-x 4 root root 4.0K Sep 20  2022 ..
-rw------- 1 vrms vrms 923M Oct 13 09:09 java_pid#####.hprof
-rw------- 1 vrms vrms 2.8G Oct  2 08:44 java_pid######.hprof

Environment

VR 9.0.2.x

Cause

Java_pid files are created when HMS service run out of memory.

Resolution

1. Take a snapshot of the VR.

cd /opt/vmware/heapdump

2.Stop HMS service.

service hms stop

3. Delete  java files.

rm -r java_pid*

4. Restart VR vm.

5. If VR pair show disconnected, connect to VR VAMI https:VR_IP:5480 and "Reconfigure" appliance with the vCenter.

6. Increase memory for the VR.